PDA

View Full Version : Problems with Princeton Tech EcoFlare



MxDiver
08-10-2007, 08:54
When I ordered my EcoFlare the light cone had some small cracks on the base, which allowed some leaking. I ordered a replacement cone, when the cone arrived I looked at it and it was fine. I put the cone on the light, and after a few days of being on the light it is showing a small crack in the base. Right now the crack is small, it hasn't reached the o-ring so it doesn't leak (I took it on a night dive yesterday). But I'm pretty sure it will get past the o-ring fairly quick. Has anyone else have had this problem?

ScaredSilly
08-12-2007, 11:11
I would give a call to the Princeton Tec folks ... they have always been helpful in fixing problems and sending free replacement parts.

MxDiver
08-12-2007, 17:18
I did call them, and they send they would send a new cone, but it I never got it so I opted to buy a mew one form ST, now is cracking again, I know if talk to Joe or Larry they will take care of me, but I don't want to abuse their good will for something that may be Princeton’s problem.

ScubaToys Larry
08-12-2007, 17:42
Don't worry about abusing us... we kind of enjoy it! :smiley2:

I have not seen that problem before with those, so I'm wondering if perhaps you are cranking those puppies down a bit too tight. Just finger tip tight will do it. Just to the o-ring seals... Don't honk down on it.

But not a problem, next time you need something, just remind us and we can toss one in your box, we'll make princeton give us a new one - and you won't have to worry about sending it back from there.

Just let us know!

MxDiver
08-13-2007, 22:37
Thanks Larry.
I screw it down only enough for it to turn on, which happens when the cone almost reaches the base, the o-ring ends up about 1/8” into the cone, Should the LED turn on before I screw it down so much?