View Full Version : New Aeris A300 CS - won't turn on after firmware update

11-04-2014, 22:40
HELP! Just bought the Aeris A300 CS. After installing DiverLog Lite for my Mac as suggested by Aeris, the first thing it wanted me to do to add my dive computer was update my firmware. It made it through all of the screens, except right before the last one it said ERROR, then it goes to the screen that says "UPDATING FIRMWARE WAIT FOR PC MESSAGE". I never got another message after that and it wouldn't let me proceed any further. The Next/Back buttons wouldn't work. I decided to give it time, so I walked off and did something else and came back and still the same thing. It was stuck. Didn't know what to do but unplug it from the computer. I couldn't get the message to go away, no matter what combination of buttons I pushed and for how long. Then I remembered it has a battery, I'll just remove the battery and maybe it will reset itself. Wrong. Haven't been able to get it to turn back on since. I've read through all manuals, hard copy and online and can't find any help. (Haven't called Aeris yet). I did put another battery in it just to see, still doesn't turn on, but the alarm goes off continuously when I do that, so I have it unscrewed until I figure out what to do.

Newbie in the first place and starting to think this might be too complicated of a dive computer just going through the pages and pages of info.

Any suggestions?

11-05-2014, 07:32
Best course of action is to call Aeris customer support:

(800) 647-0605 or info2@diveaeris.com (hello@oceanicusa.com)

It sounds like the computer get stuck always between the downloads and forgot it was a computer. Looking at the computer, it's pretty straight forward. Give it a few dives to get used to it and then rethink it. A lo of pages for simple tasks. I thought the same thing with my computer when I first got it, but now it's second nature.

11-05-2014, 20:47
My name is Joey. I am the Product Manager at Scubatoys. I am sorry to hear you are having such problems with your new computer. It is new to the market and of course like most new things there are a few bugs that need to be fixed but this is not typical. Unfortunately the firmware updates aren’t exactly straight forward and don’t really have the best of instructions but even without instructions I don’t see it causing this issue. I’m not sure if you purchased it from us or not but I would be happy to help you with it in the store. I’ve only used the A300cs once just to demo it. Therefore I don’t have enough experience to solve it from here but I can certainly give them a call at the factory and get it worked out one way or another.
The A300cs is an amazing computer. First of its kind in some ways. Definitely the way to go. Allows you to get the most out of your dives. With the color changing display, LED and Sound alarms, you can just enjoy your dives and it will prompt you when you need to make an adjustment. Most of the settings are things that you only have to set once.

11-13-2014, 19:17
Hi Joey,

Sorry, just seeing your reply. I did buy it at ScubaToys from Wayne. I did call and talk to Aeris and they gave me a RMA# to return it. Since I was waiting for the rest of our order to come in with you guys, I was waiting until I got the call before I sent it back to Aeris. I will bring it back up when I come in to pick up our BCD's. I'll bring along my paperwork also just in case. I just need it fixed and ready to test and dive before our trip in Dec. And I do keep hearing I'll grow into the computer.

Since I had trouble with mine, I'm afraid to touch my husband's now (actually I think I was told not to touch it). But I'll need to find out the best way to upload the info from the DC. I have both a Mac, PC and I think it will even upload to an app on the phones. I'll get a lesson when I come in.

Thanks for the reply!!!