PDA

View Full Version : zeagle octo Z



paintsnow
10-29-2007, 00:47
lately my octo z has been acting up.
if i hook it up to a tank of air and open up the valve, everything is fine, then after a few seconds a small hiss starts to develop.

it does bubble when i put a little but of water on the metal bar that you can see through the mouth piece.

it doesn't bubble during dives though, and it seems to only hiss above water when the unit is held above the tank valve.

im thinking i have to either adjust my cracking pressure or my IP, im just not sure which

and whatever one it is, can i adjust it myself or do i have to send it in?

i can change a light bulb and do some light wiring in case larry sees this, so i wouldnt have an issue doing it if i dont need any special tools (i think IP is adjusted in the first stage right? so i know i cant do that).

thanx for the help, i just dont want any issues popping up on me in the middle of a dive

and i dont want to lose air if i forget, (it keeps leaking even if you set it down below the valve if that helps).

thanks in advance
-paintsnow

ScubaToys Larry
10-29-2007, 05:25
What you are describing actually does not sound like a problem with the octo z, but a problem with your 1st stage. If on the surface, you air it up... and then it takes a few seconds, and it starts free flowing. Now do this, unhook it an wait.. you'll probably see that your primary will start free flowing in a bit.

It really seems like you have an IP creep, which means the seat in the first stage is slowly letting the IP climb up until it gets to the point where it will open up one of the regs... But then you hit a purge, it will drop back down for a second, then start creeping up again.

Try you reg without, and maybe try the octo z on another reg to determine if the problem is the 1st or 2nd.

Puffer Fish
10-29-2007, 12:11
What you are describing actually does not sound like a problem with the octo z, but a problem with your 1st stage. If on the surface, you air it up... and then it takes a few seconds, and it starts free flowing. Now do this, unhook it an wait.. you'll probably see that your primary will start free flowing in a bit.

It really seems like you have an IP creep, which means the seat in the first stage is slowly letting the IP climb up until it gets to the point where it will open up one of the regs... But then you hit a purge, it will drop back down for a second, then start creeping up again.

Try you reg without, and maybe try the octo z on another reg to determine if the problem is the 1st or 2nd.


Excellent advice, I would add that if you have a IP creep issue, you need to measure it without any low pressure lines on the first stage, or the leak can be very hard to see... and don't just let it creep up to tank pressure, if it is leaking...

Note: I have seen someone test for this, and remove the second stages and leave the inflator hose, and when they did, the IP went to the point of blowing up the inflator hose.

paintsnow
10-29-2007, 20:27
so how much would that cost to fix?
i bought the reg from you larry in june

you can pm me the quote if you like

ScubaToys Larry
10-30-2007, 03:09
If you bought a reg from us in June... and you're experiencing a slow intermediate pressure creep and free flow, fixing that would be... uh.. let me think here... 6 plus 7... ummm carry the one, multply by uhhh... Yea ok I got it. Free!

Just send us all the parts, and so we know what's going on, just print out the first page of posts from this thread. We'll fix it up and return it. No charge.

paintsnow
10-31-2007, 01:13
how do you suggest i pack it?
i dont want to damage them even more soooo...

put them in the scubatoys reg bag and then put that in a box filled with peanuts?

or should i do something different.

im not too good with this whole packaging thing...if you cant tell

kyfriedchipper
10-31-2007, 01:50
sounds like service time - good thing you have ST

NitroWill
10-31-2007, 02:00
how do you suggest i pack it?
i dont want to damage them even more soooo...

put them in the scubatoys reg bag and then put that in a box filled with peanuts?

or should i do something different.

im not too good with this whole packaging thing...if you cant tell


Just wrap the octoz a couple times w/ bubble wrap or surround with peanuts and itll be just fine - just make sure its an appropriate size box as freespace causes movement and movement causes damage!

DougNR
11-08-2007, 07:51
I am experiencing a similar problem as the OP with my fairly new Octo-Z...

I get a whisper of escaping air. It does not begin until I take a breath from it or press the purge. Once it begins however, I can't stop it entirely. Popping the inflator button will reduce it or stop it for a second or two, but it will return.

To isolate the possibility of IP creep suggested by Larry for the OP's problem, I put the LP hose on my daughter's very recently serviced 1st stage. Same problem.

Larry - If you see this post, is there an adjustment I can make to correct the problem? The Octo-Z has about 8 dives on it since new and was purchased from ST in your initial batch after release.

I noted this problem while checking my gear last night for an upcoming dive opportunity in the Bahamas. I'm thinking this is not a show stopper on the Octo-Z as the escaping air is minor and MAY not be an issue once the unit is submerged and/or while the primary is in use, but I'd appreciate a more expert view on that.

Thanks to all for responding.

Doug

ScottZeagle
11-08-2007, 11:03
I'll get back with you guys in a few...

:)

DougNR
11-08-2007, 12:19
I'll get back with you guys in a few...

:)

Thanks Scott. I would really appreciate your opinion on this.

Doug

ScottZeagle
11-08-2007, 14:26
I have been talking with Jim Fox, our resident reg expert, and he can come up with a dozen reasons why this might be happening...

Really, the best thing to do is probably send it to Scuba Toys or Zeagle and have us look at it...then we can let you know for sure what the issue is and get it fixed!!

Thanks,

Scott

DougNR
11-08-2007, 14:41
I have been talking with Jim Fox, our resident reg expert, and he can come up with a dozen reasons why this might be happening...

Really, the best thing to do is probably send it to Scuba Toys or Zeagle and have us look at it...then we can let you know for sure what the issue is and get it fixed!!

Thanks,

Scott


Thanks very much Scott.

I'll send it back to ST ASAP. Any thoughts on the safety of using it as is? As I said, I have no idea at this point if the leak would continue submerged or while the primary is being used. I don't wish to put you in a corner from a safety point of view, but if its clearly usable I had plans for that rascal on Sunday!

Doug

ScottZeagle
11-08-2007, 15:06
Doug,

It shouldn't be a problem to use it...

Joey is a good tech and I'm sure that he will get you fixed up!

Thanks,

Scott

Anne Eastwell
11-08-2007, 15:36
Sounds similar to the problem I had on my first dive with new regs... I sent them straight back to the distributor and he's serviced them and sending them back as we speak.

Next dive will be the test.

DougNR
11-08-2007, 18:30
Things occasionally happen to the best of products. I'm a Zeagle fan and this does not sour me on their products in the least. The only problem is here in Florida the diving is year round and I hate for my newest toy to be out of pocket!

paintsnow
11-08-2007, 20:08
yeah, mines one of the first too
i think its s/n 83 or 63
i forgot and cant check as i already sent it in.

oh and scott, is there any news on the screw in valve to keep air in the bladder when using an Octo-Z

i know i read a tread on it and you said you had to keep quiet until it was done.

just wondering if you have a date or guess for it

thanks a bunch

ScottZeagle
11-09-2007, 07:55
oh and scott, is there any news on the screw in valve to keep air in the bladder when using an Octo-Z

i know i read a tread on it and you said you had to keep quiet until it was done.

just wondering if you have a date or guess for it

thanks a bunch

Hmmmm....let me see if I can find a camera...

:)

paintsnow
12-12-2007, 18:07
so whats going on with the product scott?
did you find a camera?
:P