View Full Version : Aeris T3 and VT3 (tech support)

07-22-2007, 11:12
Larry / Joe,

I have the T3, and just checked the serial number and the firmware rev numbers.
According to this;

Mine is one of those needing the firmware upgrade. I follow the instructions ie press 3 times while it boots up, but it never goes into BCF mode.
I then have to wait like an hr to for the dang thing to turn itself off to try agin!

how in the heck, do I turn the stupid dive computer off?? I never did see that in the manual. (only thing I saw was to remove battery).. Like I want to do that just to turn it off! ?
Is there a top secret button pushing sequence to turn the damn thing off? or do i just have to wait on hr or more for it to go to sleep?

My wife's VT3 is up2date with the rev number.
As a side note, her vt3 shuts off in about 8/10 mins of none use.

(pretty bad if you ask me, when a linux geek can not figure out how to turn off a computer :) lolol )))

07-22-2007, 13:21
check out this link:


07-22-2007, 14:53
To be honest, I followed the video and pushed the buttons when they did and my VT3 come up right. I tried it before, I'd swear I did it at the same rate but it didnt work.
<DIV>After the upgrade which is only needed if you dive with buddies who have the computer (I do) then it never seems to reset and just stop. I took the time to remove the battery and replace it with a new one since I've been diving with mine for over a year now.</DIV>

07-22-2007, 15:14
Follow the last post

Try unplugging everything and then do things in this order:

1. Plug cable into PC's USB port by itself (not connected to VT3 yet)

2. Start software

3. Plug VT3 in.

4. During boot up hit A 3 times

5. Update.

I have found if you plug the VT3 in first before plugging in the USB to
the PC, things may not work. Or if you start the software with the VT3
plugged in already it may not work. But you need to have the USB cable
by itself (no VT3) plugged into the PC to start the software.

worked like a champ!

07-22-2007, 15:26
well scratch that-
even though it says upgrade complete it still showing
r1C as the firmware rev number

Jeeze , the battery cover is stuck under the watchband. How you get it off without tearing off the watch band or breaking the battery cover ring?

07-23-2007, 18:55
Did you get it figured out? Mine came off pretty easy with the supplied tool. The battery cover is just a tight fit, you can get it off with your fingernails, at least I was able to and I don't have much nail because I dive a drysuit.

07-23-2007, 19:47
Just part if the lip to the batter cover was stuck under the band for some reason.

the info that was posted here yesterday
was wrrong.

I called Aeris, and now the post reflects that the Aeris should only have the r1C revision and not the r1F revision number.