PDA

View Full Version : Zeagle zx50D problem



kancho
02-22-2008, 11:51
Anyone have their ZX 50D free flow on them? Mine did.. The BC wouldn't even inflate. The air coming out of the reg wasn't high but it ended my dive.. ANyone have that experience?

mm_dm
02-22-2008, 12:39
I've got three of them and haven't had trouble with any of them. When was it serviced last?

kancho
02-22-2008, 12:43
It was the 5th Dive (less than 2 months old), 3rd cold water dive, it free flowed. But the weather wasn't good but mine was the only one to free flow. I felt sorry for my dive buddy.. Oh well will try it again today and see..

mm_dm
02-22-2008, 13:00
That's too soon. Try soaking the 2nd stage in some warm water for about 15 mins and shake it out real good. Don't depress the purge while you're doing this. I soak mine after every dive. Sometimes a little piece of sand or some kind of crap gets wedged between the lever and the diaphram. You can also mount the first stage on a cylinder, turn the pressure on and run water through the second stage with the purge depressed. Let the second stage purge some on its' own after you've stopped pouring water into it. If that doesn't work I'd take it back to the shop you bought it from and see if there is a problem.

Normally, these are pretty reliable regs, even down to 40 degree water, even without the environmental sealing. Good luck!

I'm sure Scott or someone will show up here soon with some more advice.

kancho
02-22-2008, 14:31
Thanks I will do that. The temp was 33F in the water.. I also had problems with my comp. It didn't work after it hit 34/33F haha. After my ice dive I will send it in to ST so it can be checked out. The comp is less than 6 months old.. Too soon to be broken.. It worked only once in cold water. Works great in warm water though.

mm_dm
02-22-2008, 14:43
That's pretty chilly. If flushing doesn't work you may need the environmental kit for the first stage, I think ST has them.

fireflock
02-22-2008, 15:19
Do you know anyone who can help you with some basic troubleshooting like determining the IP?

33 is fricken cold. That could well have been the problem.

Rich

Chad
02-22-2008, 15:34
I think the ZX 50D's come with the enviro kit. Do they not?

mm_dm
02-22-2008, 15:41
Yes, you're right, I checked and they do come with the enviro kit. All my regs are older and I haven't had them in water quite as cold as the OP has. Something doesn't sound right about the reg...Zeagle makes some pretty tough regs.

fireflock
02-22-2008, 16:21
You don't need a manual to check the IP, and you don't need to open or unscrew anything. You just need one of these:
Dive Rite Intermediate Pressure Gauge, DIR and Technical, Dive Rite, Dive Rite Intermediate Pressure Gauge (http://www.scubatoys.com/store/detail.asp?PRODUCT_ID=Dive_+Rite_Intermediate_Pres sure_Gauge)

It plugs into your BC inflator hose. It's an easy way to catch problems before they develop or to start figuring out what is wrong in the field.

Rich

mm_dm
02-23-2008, 06:01
Yeah, I thought twice about whatever point I was trying to make and deleted the post with the link. With the guage he could at least isolate the problem if the pressure reading is within range from the first stage. I wonder if the OP has had any problems with his octopus or whatever safe second he's using and whether the reg is under warranty.

ScottZeagle
02-25-2008, 07:23
I suggest taking it back to the shop you bought it from and having them check it out! Otherwise, you can send an email to "tech AT zeagle DOT com" and Jim Fox can give you a few ideas...

Thanks,

Scott

kancho
02-25-2008, 11:04
I soaked it for a while and ran air through it to make sure there is no sediments stuck in there. Worked perfectly during my Ice Dive. It was great.. Other regs had some issues.. If you know a reg that can handle a ice dive you know it can take anything haha. I put my 2 cents in the reg section. My computer console is another story. it is a total lemon. Logs one dive and not the other 2. Will definitely send it back for service. After the temps reads 33 or 34F just dies. I have an alternate depth guage/bottom timer but..