Results 1 to 4 of 4

Thread: Valve install issue

  1. #1
    TadPole
    Join Date
    08/10/2013
    Location
    United States
    Posts
    1

    Valve install issue

    Hello all

    I am in the process of assembling a set of doubles and have met with a valve problem. The tanks are brand new xs scuba steel 100s. The valves are new Thermapros. I have lightly christolubed the threads on both valves and tanks. However, for both valves on both tanks, I find that when the valves are screwed in about 3/4 of the way into the tank, they stick and will go no further. In my experience with singles, valves usually hand tighten all the way down with no wrench needed (except for torque at the final tightening), so I have been reluctant to use a wrench to force anything here. Does anyone have any advice on what might be the problem or on next steps to solve it?

    Thanks in advance!

  2. #2
    Guppy
    Join Date
    02/25/2012
    Location
    Comanche, Ok
    Posts
    108
    Images
    16
    Try to determine which part is the problem first. Do you have an AL 80 for example? If so drain it and remove the valve and try installing it in the new tank. If it goes in ok its probably the valves. Or try putting one of the new valves in the AL tank. After I determined the faulty component I would get support from where you purchased it. I believe you said they were both new.
    If it doesn't fit, force it. If it breaks it needed to be replaced anyway.

  3. #3
    Barracuda Founding Member
    Join Date
    07/10/2007
    Location
    Here and there
    Posts
    1,469
    I like Steveo's advice.

    Lube the o-rings very lightly. A dab on your finger with do both o-rings.

    Where did you buy them. I would call them up for advice.

    I had a pair of doubles where the isolation manifold just wouldn't work with the bands. Called the manufacturer and it was a problem with a new mold for the bands. They spaced the tanks just a little too far apart. Sent me new bands and all was good.

    XS is a good company and I'm sure they can help.

  4. #4
    The valve should screw into the tank easily. If it is stopping 3/4 the way in, you most likely got sent the metric version. If you use a wrench to install it down to the o-ring, you will most likely damage threads.
    Ray Contreras
    www.CompressorStuff.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Should I install Drysuit Gloves?
    By snagel in forum Dry Suits
    Replies: 36
    Last Post: 02-23-2011, 11:58
  2. Check valve for P-Valve
    By skdvr in forum Dry Suits
    Replies: 2
    Last Post: 01-13-2009, 20:55
  3. Dive Alert/I3 install question
    By saltfly in forum Accessories
    Replies: 0
    Last Post: 11-30-2007, 09:07
  4. How do I install hose boot
    By citykid in forum Accessories
    Replies: 3
    Last Post: 10-28-2007, 21:13
  5. How to install Manta's spring straps?
    By Judestudio in forum Mask / Snorkels / Fins
    Replies: 6
    Last Post: 07-19-2007, 16:23

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •